Archiv der Kategorie: Allgemein

Windows thumbnail cache size

Recently I had the problem because windows is not able to cache the thumbnails for a folder with a hugh size of pictures. I found some registry values which helps me to increase this size.

The following RegEdit script will change the „Max Cached Icons“ from 512 to 4095. I tested it with windows 7 and it works for pictures and movies. Just copy/paste it to a file called „thumbnail_cache.reg“ and execute it with a double click on it.

REGEDIT4

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\explorer]
„Max Cached Icons“=“4095“

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\explorer\Advanced\IconCache]
„Text“=“Icon Cache Groesse“
„Type“=“group“
„Bitmap“=“SHDOC401.DLL,6“
„HelpID“=“update.hlp#51140“

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\explorer\Advanced\IconCache\Small]
„RegPath“=“Software\\Microsoft\\Windows\\CurrentVersion\\Explorer“
„Text“=“1024 Icons“
„Type“=“radio“
„CheckedValue“=“1023“
„ValueName“=“Max Cached Icons“
„DefaultValue“=“4095“
„HKeyRoot“=dword:80000002
„HelpID“=“update.hlp#51140“

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\explorer\Advanced\IconCache\Medium]
„RegPath“=“Software\\Microsoft\\Windows\\CurrentVersion\\Explorer“
„Text“=“2048 Icons“
„Type“=“radio“
„CheckedValue“=“2047“
„ValueName“=“Max Cached Icons“
„DefaultValue“=“4095“
„HKeyRoot“=dword:80000002
„HelpID“=“update.hlp#51140“

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\explorer\Advanced\IconCache\Large]
„RegPath“=“Software\\Microsoft\\Windows\\CurrentVersion\\Explorer“
„Text“=“4096 Icons“
„Type“=“radio“
„CheckedValue“=“4095“
„ValueName“=“Max Cached Icons“
„DefaultValue“=“4095“
„HKeyRoot“=dword:80000002
„HelpID“=“update.hlp#51140“

server doesn’t respond to ping though he receives it

I had following scenario:
client in client vlan
server multihomed in client vlan and server vlan with SLES 11.2 (I know that this is bad!)

the server didn’t respond to the ping from the client when the client pinged the srv vlan ip of this server. (ping came in on iface of the srv vlan but the server never send a reply)
I could proof this through tcpdump. After opening a service request at novell, the rp_filter was the solution. If this filter is set to one, the server won’t respond depending on the setting of this filter.
Set to 0 (deactivated) the server starts responding to the ping. For details please see:

http://ifup.org/2011/02/03/reverse-path-filter-rp_filter-by-example/

# enable route verification on all interfaces
net.ipv4.conf.all.rp_filter = 1